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1. Installation
1.1 System Requirements
The following are the minimum system specifications recommended to install
Automation Consultants’ SQL Infinity.
Intel Pentium III processor 700 MHz
128 Mbytes of RAM
Windows XP (all versions) or above
Microsoft .NET framework 1.1 (multiple versions can exist and run side-by-side)
Oracle Client version 8.1.7 or greater.

1.2 Installation Procedure
Prior to installing, it is important to check that a previous version of the SQL infinity
does not already exist by checking ‘Add or Remove Programs’ within Windows. If
any prior versions exist, they must be removed before installing the new version.
When you have obtained the installation set from www.ac-online-shop.com double
click SqlInfinityforOracle.msi and follow the instructions. If the system being
installed does not have the .NET runtime installed, please download and install the
.NET Framework from Microsoft and then re-start the installation.

1.3 Running SQL Infinity for the First Time
Launch SQL Infinity from the Start Menu using the start menu item Start >
Automation Consultants > SQL Infinity for Oracle.

It is now necessary to register the copy of SQL Infinity with Automation Consultants.
This is required for both purchased and evaluation editions. Click the Register button
to continue.
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1.3.1 License Key
Locate your license code by logging onto our download website at www.ac-onlineshop.com and navigating to:
My Account > Product Download and Licensing
Or alternatively by going directly to https://www.ac-online-shop.com/productslicence
The license key can be viewed by clicking on the golden key icon next to the ordered
product. Copy the License Key to your clipboard and proceed.

1.3.2 Registering the product with Automation Consultants
This is required for both purchased and evaluation editions. If the machine you have
installed SQL Infinity on is connected to the Internet, paste the License Key into the
license key field. Click the Activate button and an unlock-code will be automatically
downloaded and installed on your machine. If the machine connects to the internet via
a proxy server please provide proxy authentication credentials when requested.

If you are NOT connected to the Internet, a popup dialog box will appear. Carefully
copy the encrypted data from the Text To Server field to the clipboard then either:
On a computer that is connected to the Internet, copy the data into the
appropriate field at the following URL –
http://www.ac-online-shop.com/keyManage
Or email the data to customerservices@ac-online-shop.com
A new license key will be returned to you that you should paste into the Server
Response Text field. Click OK and the license will be installed on your machine.
If the machine is connected to the internet and you still wish to register manually,
right-click on the Activate button and select Manual and follow the above step.
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2. Getting to know SQL Infinity
2.1 Connecting to Oracle database
Please obtain database connection details from your Database Administrator. You can
either connect to the database directly or using TNS names. If you wish to connect via
TNS please make sure you have the correct tnsnames.ora file in place. You can obtain
the tnsnames.ora file from your database admin and make sure you place the file in
<Oracle client installation>/network/ADMIN/

The connection details you input will be saved for future use. If you opt to Remember
Password the details will be stored securely and make it easy for you to connect in the
future.
To load saved connection details in the future click on the connection you need and
enter the password if you haven’t opted to save. You can also double-click on the
connection to take you straight in if the password has been saved.
To remove a connection from the list, right-click on the connection and select
Remove. If you would like to test the connection, once you have loaded or entered the
connection details press the Test button.
The connection window will appear every time you open the application. You can
also switch between connections by going File > Connection.
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2.2 Browsing Database
When a successful connection to the database has been established you can use the
intuitive user interface to simplify the process of browsing the databases for
information.

To load all tables in the database press the Load all Tables button or press F6. This
will give a list of all the tables belonging to the database you have access to
depending on your access rights as set by the database administrator. If you would
like to save the list of table names to a file right-click on the left pane and press Save
to File.
To get a list of all columns in a particular table, double click on the particular table
name or press F7. This will load all available columns of that table to the left window.
If you want to search for a specific table in the database, enter the table name you
wish to search in the Table field and press Search. Likewise if you want to search for
tables containing a particular column name in the database, enter the column name in
the Column search box, ensure the Table search box is empty and press Search. To
narrow down the search you can search for both a specific table name and column
name at the same time.
The WildCard search option can be used when you don’t know what exactly you are
looking for. For example if you do a table search for “CREDIT” with the WildCard
box ticked, your result will include table names such as; “CREDIT_CARD”,
“CREDITSCORE”, “PERSONAL_CREDIT” etc.
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Most of the actions within this the main window are self-explanatory. All actions can
be executed manually by right-clicking on the table/column name or by using shortcut keys or by navigating under the Action tab.

Open Table: On the left pane select the table name you wish to open and either right
click and select Open Table or press F8. This will open a new window showing the
dataset. To save the dataset to a file right-click anywhere on the window and select
Save To File.
Filter Table: Select a table from the left pane and click filter table. Here you can
specify multiple search criteria to drill down / filter the table accordingly.
Get Row Count: On the left pane select the table name and either right click and select
Get Row Count or press F9. This will show the total number of rows in that table.
Get Distinct Values: On the right pane select the column name and either right-click
or double click and select Get Distinct Values or press F10. This will filter all
available unique values within the particular column.
The Properties F12 option will show details of the table structure including primary
keys, conditions, owners and tablespace specific to the table you have selected.
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2.3 Searching through the Database
SQL Infinity is equipped with a powerful search feature which enables you to search
for data without the need for complex sql queries.
.
If you wish to search for data, select the table then load columns to the right pane by
double clicking on the table name or by pressing F7. Right-click on the column name
and select Search.

The available operators will differ depending on the data type of the column you have
selected to search. Note the search string should match the data type. Do not include
double/single quotes in your search string to represent strings, chars etc. Depending
on the size of the table the search can take longer to complete. You have the option to
cancel the search at anytime. The result will appear in a new window.
If you want to do a more powerful multi-column data search use the Filter Table
option. Here you can specify multiple search criteria.

SQL Infinity supports parallel processing so it is important to note that you don’t have
to wait for one search to complete before you can start a new search. The results of
multiple searches will appear as and when they have completed.
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2.4 Clearing your workspace
SQL Infinity can be set as a notification icon on your desktop when you want to clear
your work space or have finished working with it. This will eliminate the need of
restarting the application. To hide SQL Infinity go to File > Hide Window or press
Ctrl+H..

By right clicking on the icon the above options are available. Double click on the icon
to unhide the SQL Infinity window.
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3. Querying the Database
3.1 SQL Query window
The SQL query window is optimised to run ANSI / ISO standard SEQUEL queries
acceptable by Oracle. Click the SQL editor tab or press Ctrl+S to open a new SQL
query window.

You can have multiple SQL windows open and each one can perform independently
without interference. Each window can be connected to different databases.
To query the database type in your SQL query in the top pane and press the start
button or press F5 . The dataset will be populated in the bottom pane. To save the
results to a file right click anywhere on the bottom pane and select Save To File.
When you type multiple queries separate them with a new line. By default the last
query will be executed. If you want to execute a different query, carefully highlight
the whole query and press F5. The time it takes to execute the query will be shown on
the bottom left hand corner.
You can save all your queries to a file by going to File > Save SQL To File
import queries back by going to File > Open SQL from File

and
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2.2 SQL Editor settings
By default AUTOCOMMIT is ON. Be aware any changes you make to the database
when running UPDATE, INSERT and DELETE queries will be saved automatically.
To switch AUTOCOMMIT OFF go to Settings > Autocommit > off. When
AUTOCOMMIT is OFF, if you wish to save changes to the database press the
commit button. To discard changes press the Rollback button.
- Rollback /
- Commit
(only available when AUTOCOMMIT is OFF)
The built-in syntax highlighter mitigates writing invalid queries. You can switch off
the Syntax highlighter to conserve system resources if needed. Go to Settings and
untick the system highlighter option to switch off.
To connect to a different database within the SQL query window go to File >
Connection.
If you wish to stop executing a query, you can do this by pressing the STOP button or
navigating to SQL > Abort. This will force the current SQL query to stop processing
and allow you to start a new query.
If there are uncommitted transactions and you try to exit the SQL window when
AUTOCOMMIT is OFF, you will be warned to either commit before you exit or
discard changes and exit anyway.
For your convenience when writing sql you can replace “select * from” with just an
asterisk (*). For example:
Select * from staff where staff_id = 1005;
Can also be written as
* staff where staff_id = 1005;
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2.2 SQL History
SQL Infinity keeps track of all your SQL queries. To access the SQL history window
go to SQL > History
within the SQL Query window.

Each query is saved along with the time stamp. You can search for a particular text or
time by entering it in the Find text box and pressing the Filter button. To reload
everything, press the Reload button. By default the file is stored in
<SQL Infinity installation path>/SQLhistory.txt.
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3. Managing Licenses
To view your license information go to Help > Manage License. From here you can
remove or update your current license. You can also register a new license key. To
register a new license key press the New License button and follow section 1.3.2.

Please remember your license key is locked to your physical machine. If you plan to
move your license to a different machine, ensure you remove the key successfully
first before registering on a new machine. You can view the number of active licenses
by going to https://www.ac-online-shop.com/productslicence. If you have to reformat
your machine while the license is still active, you should not have a problem as long
as you re-register the key from the same machine.

3.1 Remove License
To remove your licence key press the Remove button and follow the instructions. This
process will try to connect to the internet and inform the license server to release the
license key. If you don’t have an internet connection the process will offer you an
alternative manual process.
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3.2 Update License
The update process will ensure you have the correct license key version. If you
request a license key change from Automation Consultants, your license key will
reflect the changes by this process. To update press the Update button and follow the
instructions.
When the product encryption key runs out of date you will be asked to update your
product before continuing. If you fail or close the product update you won’t be able to
use SQL Infinity further. To update please press the Update Now button.

4. Support
Most problems can be resolved by closing and restarting the application. However if
the problem persists you can open a support ticket by going to
http://www.ac-online-shop.com/technicalSupport
or
email : customerservices@ac-online-shop.com
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